Back to overview
Degraded
Spam Emails
Nov 25 at 09:18pm GMT
Affected services
HSVE Helpdesk
Resolved
Nov 26 at 08:01am GMT
We have implemented a solution. We will actively monitor this incident - Thanks for your patience.
Affected services
Updated
Nov 26 at 07:43am GMT
We are still actively working to get rid of these spam emails. Please bare with us.
Affected services
Created
Nov 25 at 09:18pm GMT
We are getting lots of spam emails through on our helpdesk. This means our performance may be degraded when replying - Thanks for your understanding
Affected services