Back to overview
Downtime

HSVE Support - Mailbox Delivery

Mar 24 at 08:01am GMT
Affected services
HSVE Helpdesk

Resolved
Mar 24 at 03:15pm GMT

We have identified the root cause of the issue and the issue is now resolved.

Created
Mar 24 at 08:01am GMT

We have noticed that mail has not been coming into our freshdesk support desk. We are investigating this currently.