Back to overview
Downtime
HSVE Order System
Apr 01 at 06:37pm BST
Affected services
HSVE Store
Resolved
Apr 01 at 06:50pm BST
We have implemented a fix and are currently monitoring the issue for any irregularities.
Affected services
Updated
Apr 01 at 06:48pm BST
We have identified the root cause of the issue and are implementing a fix. Please bare with us.
Affected services
Created
Apr 01 at 06:37pm BST
The order system on the HSVE Website is currently experiencing issues.
Affected services