Back to overview
Degraded

HSVE Email System

May 29 at 03:58pm BST
Affected services
HSVE Website
HSVE Store
HSVE Helpdesk

Resolved
May 29 at 11:26pm BST

Our suppliers have implemented a fix and all email functionality should now be normal again

Updated
May 29 at 09:33pm BST

We are still waiting on our suppliers to implement a fix.

Updated
May 29 at 04:25pm BST

We have identified the root cause of this issue and are working with our suppliers to implement a fix

Created
May 29 at 03:58pm BST

We are experiencing issues with our mail server. Please bare with us whilst we investigate this and we will provide you with an update in due course.